Issue opening CodeShow source code

Oct 31, 2012 at 2:56 AM

I am running Windows 8 Pro with VS2012 RTM.

I've downloaded the source code and then went on to install SDKs as per instructions.  Then, when I attempted to open the solution the VS2012 gave me an error:

C:\temp\codeshow-html5\codeSHOW\codeSHOW.jsproj : error : Error HRESULT E_FAIL has been returned from a call to a COM component.

Anyone encountered that?

 

Thank you

Coordinator
Nov 5, 2012 at 8:56 PM

I've never seen that before. Strange. When you look in the References folder are all of the SDKs alright or do any of them have a red X?

Nov 19, 2012 at 8:24 PM

All of the SDK references are broken for me upon downloading the source. I suggest putting a lib folder at the solution root and referencing from there. I suspect they exist on your local machine in the correct location, but that TFS is ignoring them by default and not adding them to source.

Coordinator
Nov 20, 2012 at 2:52 AM
Edited Nov 20, 2012 at 3:48 AM

Instead of a lib folder, there is a bin folder at the root of the solution. It should have all of the installers. I’m not sure if there is an issue still with the version I have up there for the Telerik SDK, so if it doesn’t work or I don’t fix it in time, then just remove the reference.

Nov 24, 2012 at 8:48 AM

@codefoster,

Sorry for the lapse in my response. I only now had time to respond.  I've retried opening the VS2012 solution and the project now opens solution and the project.  My only issue now is that Telerik.UI reference is broken. It's reporting the following during compilation: "error MSB3774: Could not find SDK "Telerik.UI, Version=2012.1.912".  I am a bit unfamiliar with these project types so i'd appreciate any guidance. I did install the Telerik toolset for Windows 8.

Thank you for your time.

Nov 24, 2012 at 8:52 AM

Just saw this thread, http://codeshow.codeplex.com/discussions/402021, I think i am ok.  Thanks.

Coordinator
Nov 24, 2012 at 1:42 PM
Great. Glad it's working.

jf

From: rroman81
Sent: 11/24/2012 1:53 AM
To: jeremy.foster@live.com
Subject: Re: Issue opening CodeShow source code [codeshow:401333]

From: rroman81

Just saw this thread, http://codeshow.codeplex.com/discussions/402021, I think i am ok. Thanks.

Dec 17, 2012 at 8:20 AM

I have had the same error as the OP: ...\codeSHOW.jsproj : error : Error HRESULT E_FAIL has been returned from a call to a COM component.

Unfortunately that was the extent of the error - no clue as to what COM component or any other inkling.

Couldn't load the project no matter what I tried. Installed all the pre-requisites etc etc but not one bit of the project would load.

However... I've just found out that it turns out to be the source code control stuff. I had installed a SCC add-in for Mercurial and it was set as my default SCC provider. Setting the SCC provider to None in 'Tools | Options' allowed the project to load fine  (setting it to TFS, presumably would have worked too). 

Maybe that will help anyone who encounters this issue as I guess it could happen in other projects too.

Coordinator
Dec 17, 2012 at 7:00 PM

Great. Thanks for the input, @shunty.